Risolvere Errore Internal Server Error (Errore 500) WordPress su Aruba

Tempo di lettura: 2 minuti

A quanti di voi è successo di vedere l’errore “Internal Server Error” all’apertura del sito o solo su determinate pagine?

Tendenzialmente questo errore può presentarsi all’improvviso oppure dopo operazioni specifiche, quali aggiornamenti temi/plugins (manuali o automatici), modifiche interne ai files che non piacciono al server e/o scrittura di script personalizzati non ottimizzati.

In altri casi avviene dopo il trasferimento di un sito, che prima era ospitato su un server diverso.

Niente panico! Solitamente è un errore innocuo, è che viene esaltato troppo da questo brutto messaggio di errore. 🙂

Oggi vi mostro come risolvere il problema e più precisamente come intervenire se l’errore si presenta su siti che sono ospitati su Server di Aruba.

Ps: In realtà questa procedura vale per tutti i siti (anche non ospitati su Aruba), mi sono reso conto però, che questo errore si presenta più spesso su Aruba.

internal server error

Ecco cosa provare a fare, seguite questo ordine:

  • 1 – Refresh dei permalink. Se siamo fortunati e sufficiente salvare i permalink
    Bisogna recarsi in Impostazioni — Permalink e cliccare su Salva le modifiche senza effettuare nessun cambiamento, un semplice refresh. Provate a riaprire il sito.

Salva Permalink

  • 2 – Cancellare il file .htaccess. A volte vengono scritte regole non funzionanti o ancora peggio formattate male e quindi generano un errore sul sito, portando proprio all’internal server error.
    Se non avete creato voi un file .htaccess personalizzato potete cancellarlo tranquillamente, in caso contrario rimuovete le stringhe potenzialmente problematiche.

htaccess corrotto 1

Avete risolto con una di queste procedure? Fatemelo sapere nei commenti!

Lascia un commento